Debian DSA-2171-1 : asterisk - buffer overflow

Medium Nessus Plugin ID 52055

Synopsis

The remote Debian host is missing a security-related update.

Description

Matthew Nicholson discovered a buffer overflow in the SIP channel driver of Asterisk, an open source PBX and telephony toolkit, which could lead to the execution of arbitrary code.

Solution

Upgrade the asterisk packages.

For the oldstable distribution (lenny), this problem has been fixed in version 1.4.21.2~dfsg-3+lenny2.

For the stable distribution (squeeze), this problem has been fixed in version 1.6.2.9-2+squeeze1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=610487

https://packages.debian.org/source/squeeze/asterisk

https://www.debian.org/security/2011/dsa-2171

Plugin Details

Severity: Medium

ID: 52055

File Name: debian_DSA-2171.nasl

Version: 1.16

Type: local

Agent: unix

Published: 2011/02/22

Updated: 2020/03/12

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6

Temporal Score: 5.2

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:asterisk, cpe:/o:debian:debian_linux:5.0, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/02/21

Reference Information

CVE: CVE-2011-0495

BID: 45839

DSA: 2171