VMSA-2010-0012 : VMware vCenter Update Manager Fix for Jetty Web Server

Medium Nessus Plugin ID 52014


The remote host has an update manager installed that is affected by multiple vulnerabilities.


The version of VMware vCenter Update Manager installed on the remote Windows host is 4.0 earlier than Update 3 or 4.1 earlier than Update 1. The installed version is, therefore, potentially affected by multiple vulnerabilities in the embedded Jetty Web server :

- A directory traversal vulnerability allows a remote, unauthenticated attacker to obtain files from the remote host. (CVE-2009-1523)

- A cross-site scripting vulnerability allows a remote attacker to execute arbitrary script code in the user's browser. (CVE-2009-1524)


Upgrade to vCenter Update Manager 4.0 Update 3 / 4.1 Update 1 or later.

See Also


Plugin Details

Severity: Medium

ID: 52014

File Name: vmware_VMSA-2010-0012.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2011/02/17

Modified: 2016/11/29

Dependencies: 66908, 10107

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:vcenter_update_manager

Required KB Items: SMB/VMware vCenter Update Manager/Version, SMB/VMware vCenter Update Manager/Build, SMB/VMware vCenter Update Manager/Path

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/07/19

Vulnerability Publication Date: 2010/07/19

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-1523, CVE-2009-1524

BID: 34800

OSVDB: 54186, 54187

VMSA: 2010-0012

CWE: 22, 79