Apache Tomcat 7.x < 7.0.6 Manager Interface XSS

Medium Nessus Plugin ID 51976

Synopsis

The remote web server is affected by a cross-site scripting vulnerability.

Description

According to its self-reported version number, the instance of Apache Tomcat 7.x listening on the remote host is prior to 7.0.6. It is, therefore, affected by a cross-site scripting vulnerability in its HTML Manager interface. A remote attacker can exploit this to inject code into a user's browser via a crafted URL.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update Apache Tomcat to version 7.0.6 or later.

See Also

http://www.nessus.org/u?1b4b157f

https://seclists.org/fulldisclosure/2011/Feb/78

Plugin Details

Severity: Medium

ID: 51976

File Name: tomcat_7_0_6.nasl

Version: 1.21

Type: remote

Family: Web Servers

Published: 2011/02/14

Updated: 2018/11/15

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/01/14

Vulnerability Publication Date: 2011/02/05

Reference Information

CVE: CVE-2011-0013

BID: 46174

Secunia: 43198

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990