Debian DSA-2160-1 : tomcat6 - several vulnerabilities

Medium Nessus Plugin ID 51959

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities were discovered in the Tomcat Servlet and JSP engine :

- CVE-2010-3718 It was discovered that the SecurityManager insufficiently restricted the working directory.

- CVE-2011-0013 It was discovered that the HTML manager interface is affected by cross-site scripting.

- CVE-2011-0534 It was discovered that NIO connector performs insufficient validation of the HTTP headers, which could lead to denial of service.

The oldstable distribution (lenny) is not affected by these issues.

Solution

Upgrade the tomcat6 packages.

For the stable distribution (squeeze), this problem has been fixed in version 6.0.28-9+squeeze1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=612257

https://security-tracker.debian.org/tracker/CVE-2010-3718

https://security-tracker.debian.org/tracker/CVE-2011-0013

https://security-tracker.debian.org/tracker/CVE-2011-0534

https://packages.debian.org/source/squeeze/tomcat6

https://www.debian.org/security/2011/dsa-2160

Plugin Details

Severity: Medium

ID: 51959

File Name: debian_DSA-2160.nasl

Version: 1.11

Type: local

Agent: unix

Published: 2011/02/14

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:tomcat6, cpe:/o:debian:debian_linux:6.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/02/13

Reference Information

CVE: CVE-2010-3718, CVE-2011-0013, CVE-2011-0534

BID: 46164, 46174, 46177

DSA: 2160