Apache Tomcat 5.5.x < 5.5.32 HTML Manager Interface XSS

Medium Nessus Plugin ID 51957


The remote web server is affected by a cross-site scripting vulnerability.


According to its self-reported version number, the instance of Apache Tomcat 5.5.x listening on the remote host is prior to 5.5.32. It is, therefore, affected by a cross-site scripting vulnerability in its HTML Manager interface.

An input validation error exists in the HTML Manager interface of Tomcat that may allow a remote attacker to inject code into a user's browser via a crafted URL.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 5.5.32 or later.

See Also


Plugin Details

Severity: Medium

ID: 51957

File Name: tomcat_5_5_32.nasl

Version: 1.22

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 2011/02/11

Updated: 2020/03/11

Dependencies: 130175, 39446, 130590

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2011-0013

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/02/01

Vulnerability Publication Date: 2011/02/04

Reference Information

CVE: CVE-2011-0013

BID: 46174

Secunia: 43198

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990