Flash Player < 10.2.152.26 Multiple Vulnerabilities (APSB11-02)

High Nessus Plugin ID 51926

Synopsis

The remote Windows host contains a browser plug-in that is affected by multiple vulnerabilities.

Description

The remote Windows host contains a version of Adobe Flash Player earlier than 10.2.152.26. Such versions are potentially affected by multiple vulnerabilities :

- An integer overflow exists that could lead to code execution. (CVE-2011-0558)

- Multiple memory corruption vulnerabilities exist that could lead to code execution. (CVE-2011-0559, CVE-2011-0560, CVE-2011-0561, CVE-2011-0571, CVE-2011-0572, CVE-2011-0573, CVE-2011-0574, CVE-2011-0578, CVE-2011-0607, CVE-2011-0608)

- A library-loading vulnerability exists that could lead to code execution. (CVE-2011-0575)

- A font-parsing vulnerability exists that could lead to code execution. (CVE-2011-0577)

Solution

Upgrade to Flash Player 10.2.152.26 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb11-02.html

Plugin Details

Severity: High

ID: 51926

File Name: flash_player_apsb11-02.nasl

Version: 1.19

Type: local

Agent: windows

Family: Windows

Published: 2011/02/09

Updated: 2018/07/12

Dependencies: 28211

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/02/08

Vulnerability Publication Date: 2011/02/08

Reference Information

CVE: CVE-2011-0558, CVE-2011-0559, CVE-2011-0560, CVE-2011-0561, CVE-2011-0571, CVE-2011-0572, CVE-2011-0573, CVE-2011-0574, CVE-2011-0575, CVE-2011-0577, CVE-2011-0578, CVE-2011-0607, CVE-2011-0608

BID: 46186, 46188, 46189, 46190, 46191, 46192, 46193, 46194, 46195, 46196, 46197, 46282, 46283