OpenSSH Legacy Certificate Signing Information Disclosure

medium Nessus Plugin ID 51920
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Remote attackers may be able to access sensitive information.

Description

According to the banner, OpenSSH 5.6 or 5.7 is running on the remote host. These versions contain an information disclosure vulnerability.
This vulnerability may cause the contents of the stack to be copied into an SSH certificate, which is visible to a remote attacker. This information may lead to further attacks.

Solution

Upgrade to OpenSSH 5.8 or later.

See Also

http://www.openssh.com/txt/legacy-cert.adv

http://www.openssh.com/txt/release-5.8

Plugin Details

Severity: Medium

ID: 51920

File Name: openssh_58.nasl

Version: 1.10

Type: remote

Family: Misc.

Published: 2/9/2011

Updated: 7/16/2018

Dependencies: ssh_detect.nasl

Risk Information

VPR

Risk Factor: Low

Score: 3.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Exploit Ease: No known exploits are available

Patch Publication Date: 2/4/2011

Vulnerability Publication Date: 2/4/2011

Reference Information

CVE: CVE-2011-0539

BID: 46155

Secunia: 43181