Mandriva Linux Security Advisory : pango (MDVSA-2011:020)

High Nessus Plugin ID 51865

Synopsis

The remote Mandriva Linux host is missing one or more security updates.

Description

A vulnerability has been found and corrected in pango :

Heap-based buffer overflow in the pango_ft2_font_render_box_glyph function in pango/pangoft2-render.c in libpango in Pango 1.28.3 and earlier, when the FreeType2 backend is enabled, allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted font file, related to the glyph box for an FT_Bitmap object (CVE-2011-0020).

Packages for 2009.0 are provided as of the Extended Maintenance Program. Please visit this link to learn more:
http://store.mandriva.com/product_info.php?cPath=149 products_id=490

The updated packages have been patched to correct this issue.

Solution

Update the affected packages.

Plugin Details

Severity: High

ID: 51865

File Name: mandriva_MDVSA-2011-020.nasl

Version: 1.9

Type: local

Published: 2011/02/04

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64pango1.0-devel, p-cpe:/a:mandriva:linux:lib64pango1.0_0, p-cpe:/a:mandriva:linux:lib64pango1.0_0-modules, p-cpe:/a:mandriva:linux:libpango1.0-devel, p-cpe:/a:mandriva:linux:libpango1.0_0, p-cpe:/a:mandriva:linux:libpango1.0_0-modules, p-cpe:/a:mandriva:linux:pango, p-cpe:/a:mandriva:linux:pango-doc, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2010.0, cpe:/o:mandriva:linux:2010.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2011/02/03

Reference Information

CVE: CVE-2011-0020

MDVSA: 2011:020