VLC Media Player < 1.1.7 MKV Input Validation Vulnerability

High Nessus Plugin ID 51851


The remote Windows host contains an media player that is affected by a code execution vulnerability.


The version of VLC media player installed on the remote host is earlier than 1.1.7. Such versions are reportedly affected by the following vulnerability :

- Insufficient input validation when parsing a specially crafted Matroska or WebM (MKV) file can be exploited to execute arbitrary code.


Upgrade to VLC Media Player version 1.1.7 or later.

See Also



Plugin Details

Severity: High

ID: 51851

File Name: vlc_1_1_7.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2011/02/02

Modified: 2014/11/07

Dependencies: 31852

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/02/01

Vulnerability Publication Date: 2011/01/30

Exploitable With

Core Impact

Metasploit (VideoLAN VLC MKV Memory Corruption)

Reference Information

CVE: CVE-2011-0531

BID: 46060

OSVDB: 70698