Mandriva Linux Security Advisory : pcsc-lite (MDVSA-2011:015)

Medium Nessus Plugin ID 51806


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in pcsc-lite :

Stack-based buffer overflow in the ATRDecodeAtr function in the Answer-to-Reset (ATR) Handler (atrhandler.c) for pcscd in PCSC-Lite 1.5.3, and possibly other 1.5.x and 1.6.x versions, allows physically proximate attackers to cause a denial of service (crash) and possibly execute arbitrary code via a smart card with an ATR message containing a long attribute value (CVE-2010-4531).

Packages for 2009.0 are provided as of the Extended Maintenance Program. Please visit this link to learn more: products_id=490

The updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 51806

File Name: mandriva_MDVSA-2011-015.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2011/01/28

Modified: 2014/01/23

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.4

Temporal Score: 3.8

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64pcsclite-devel, p-cpe:/a:mandriva:linux:lib64pcsclite-static-devel, p-cpe:/a:mandriva:linux:lib64pcsclite1, p-cpe:/a:mandriva:linux:libpcsclite-devel, p-cpe:/a:mandriva:linux:libpcsclite-static-devel, p-cpe:/a:mandriva:linux:libpcsclite1, p-cpe:/a:mandriva:linux:pcsc-lite, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2010.0, cpe:/o:mandriva:linux:2010.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/01/20

Reference Information

CVE: CVE-2010-4531

BID: 45450

MDVSA: 2011:015