Mandriva Linux Security Advisory : perl-CGI (MDVSA-2011:008)

Medium Nessus Plugin ID 51800


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in perl-CGI :

Unspecified vulnerability in 3.50 and earlier allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via unknown vectors. NOTE: this issue exists because of an incomplete fix for CVE-2010-2761 (CVE-2010-4411).

Packages for 2009.0 are provided as of the Extended Maintenance Program. Please visit this link to learn more: products_id=490

The updated packages have been upgraded to the latest version (3.51) which is not affected by this issue and in turn also brings many bugfixes.


Update the affected perl-CGI and / or perl-CGI-Fast packages.

Plugin Details

Severity: Medium

ID: 51800

File Name: mandriva_MDVSA-2011-008.nasl

Version: $Revision: 1.11 $

Type: local

Published: 2011/01/28

Modified: 2016/05/17

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:perl-CGI, p-cpe:/a:mandriva:linux:perl-CGI-Fast, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2010.0, cpe:/o:mandriva:linux:2010.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/01/14

Reference Information

CVE: CVE-2010-4411

BID: 45145

OSVDB: 69588

MDVSA: 2011:008