Asterisk main/utils.c ast_uri_encode() CallerID Information Overflow (AST-2011-001)

medium Nessus Plugin ID 51644
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A telephony application running on the remote host is affected by a buffer overflow vulnerability.

Description

Using a specially crafted caller ID string, an authenticated user placing an outgoing call through the remote Asterisk server can cause a buffer overflow leading to an application crash or execution of arbitrary code.

Successful exploitation may require that the SIP channel driver is configured with the 'pedantic' option enabled.

Solution

Upgrade to Asterisk 1.4.38.1 / 1.4.39.1 / 1.6.1.21 / 1.6.2.15.1 / 1.6.2.16.1 / 1.8.1.2 / 1.8.2.2, Asterisk Business Edition C.3.6.2 or later.

See Also

http://downloads.asterisk.org/pub/security/AST-2011-001.html

Plugin Details

Severity: Medium

ID: 51644

File Name: asterisk_ast_2011_001.nasl

Version: 1.17

Type: remote

Published: 1/21/2011

Updated: 6/27/2018

Dependencies: asterisk_detection.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2011

Vulnerability Publication Date: 1/11/2011

Reference Information

CVE: CVE-2011-0495

BID: 45839

Secunia: 42935