Fedora 13 : perl-Convert-UUlib-1.34-1.fc13 (2011-0062)

High Nessus Plugin ID 51577


The remote Fedora host is missing a security update.


Perl extension Convert::UUlib 1.34 :

- Fix a one-byte-past-end-write buffer overflow in UURepairData (reported, analysed and testcase provided by Marco Walther)

- Quoted-printable decoding was completely broken, try a fix

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected perl-Convert-UUlib package.

See Also


Plugin Details

Severity: High

ID: 51577

File Name: fedora_2011-0062.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2011/01/20

Modified: 2015/10/20

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:perl-Convert-UUlib, cpe:/o:fedoraproject:fedora:13

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2011/01/03

Reference Information

FEDORA: 2011-0062