GLSA-201101-02 : Tor: Remote heap-based buffer overflow

Critical Nessus Plugin ID 51532


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201101-02 (Tor: Remote heap-based buffer overflow)

Tor contains a heap-based buffer overflow in the processing of user or attacker supplied data. No additional information is available.
Impact :

Successful exploitation of this vulnerability may allow an unauthenticated remote attacker to execute arbitrary code with the permissions of the Tor user, or to cause a Denial of Service.
Workaround :

There is no known workaround at this time.


All Tor users should upgrade to the latest stable version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/tor-'

See Also

Plugin Details

Severity: Critical

ID: 51532

File Name: gentoo_GLSA-201101-02.nasl

Version: $Revision: 1.6 $

Type: local

Published: 2011/01/17

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:tor, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2011/01/15

Reference Information

CVE: CVE-2010-1676

OSVDB: 69944

GLSA: 201101-02