Wireshark < 1.2.14 / 1.4.3 Multiple Vulnerabilities

High Nessus Plugin ID 51458

Synopsis

The remote Windows host contains an application that is affected by multiple vulnerabilities.

Description

The installed version of Wireshark is 1.2.x less than 1.2.14 or 1.4.x less than 1.4.3. Such versions are affected by the following vulnerabilities :
- An error exists in the MAC-LTE dissector that allows a series of malformed packets to cause a buffer overflow.
(5530)

- An error exists in the ENTTEC dissector that allows a series of malformed packets to cause a buffer overflow.
(5539)

- An error exists in the ASN.1 BER dissector that allows a series of malformed packets to make Wireshark exit prematurely. (5537)

Solution

Upgrade to Wireshark version 1.2.14 / 1.4.3 or later.

See Also

http://www.wireshark.org/security/wnpa-sec-2011-01.html

https://www.wireshark.org/security/wnpa-sec-2011-02.html

http://www.wireshark.org/docs/relnotes/wireshark-1.2.14.html

http://www.wireshark.org/docs/relnotes/wireshark-1.4.3.html

Plugin Details

Severity: High

ID: 51458

File Name: wireshark_1_4_3.nasl

Version: 1.14

Type: local

Agent: windows

Family: Windows

Published: 2011/01/12

Updated: 2018/11/15

Dependencies: 34112

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/01/11

Vulnerability Publication Date: 2010/12/31

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Reference Information

CVE: CVE-2010-4538, CVE-2011-0444, CVE-2011-0445

BID: 45634, 45775

Secunia: 42767