Debian DSA-2141-1 : openssl - SSL/TLS insecure renegotiation protocol design flaw

medium Nessus Plugin ID 51440
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Debian host is missing a security-related update.

Description

DSA-2141 consists of three individual parts, which can be viewed in the mailing list archive: DSA 2141-1 (openssl), DSA 2141-2 (nss), DSA 2141-3 (apache2), and DSA 2141-4 (lighttpd). This page only covers the first part, openssl.

- CVE-2009-3555 Marsh Ray, Steve Dispensa, and Martin Rex discovered a flaw in the TLS and SSLv3 protocols. If an attacker could perform a man in the middle attack at the start of a TLS connection, the attacker could inject arbitrary content at the beginning of the user's session. This update adds backported support for the new RFC5746 renegotiation extension which fixes this issue.

If openssl is used in a server application, it will by default no longer accept renegotiation from clients that do not support the RFC5746 secure renegotiation extension. A separate advisory will add RFC5746 support for nss, the security library used by the iceweasel web browser. For apache2, there will be an update which allows to re-enable insecure renegotiation.

This version of openssl is not compatible with older versions of tor. You have to use at least tor version 0.2.1.26-1~lenny+1, which has been included in the point release 5.0.7 of Debian stable.

Currently we are not aware of other software with similar compatibility problems.

- CVE-2010-4180 In addition, this update fixes a flaw that allowed a client to bypass restrictions configured in the server for the used cipher suite.

Solution

Upgrade the openssl package.

For the stable distribution (lenny), this problem has been fixed in version 0.9.8g-15+lenny11.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=555829

https://lists.debian.org/debian-security-announce/2011/msg00001.html

https://lists.debian.org/debian-security-announce/2011/msg00002.html

https://lists.debian.org/debian-security-announce/2011/msg00003.html

https://lists.debian.org/debian-security-announce/2011/msg00006.html

https://security-tracker.debian.org/tracker/CVE-2009-3555

https://security-tracker.debian.org/tracker/CVE-2010-4180

https://www.debian.org/security/2011/dsa-2141

Plugin Details

Severity: Medium

ID: 51440

File Name: debian_DSA-2141.nasl

Version: 1.19

Type: local

Agent: unix

Published: 1/10/2011

Updated: 1/4/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: High

Score: 8.3

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.5

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:openssl, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/6/2011

Reference Information

CVE: CVE-2009-3555, CVE-2010-4180

BID: 36935, 45164

DSA: 2141

CWE: 310