Ubuntu 8.04 LTS / 9.10 / 10.04 LTS / 10.10 : evince vulnerabilities (USN-1035-1)

High Nessus Plugin ID 51421

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

Jon Larimer discovered that Evince's font parsers incorrectly handled certain buffer lengths when rendering a DVI file. By tricking a user into opening or previewing a DVI file that uses a specially crafted font file, an attacker could crash evince or execute arbitrary code with the user's privileges.

In the default installation of Ubuntu 9.10 and later, attackers would be isolated by the Evince AppArmor profile.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

See Also

https://usn.ubuntu.com/1035-1/

Plugin Details

Severity: High

ID: 51421

File Name: ubuntu_USN-1035-1.nasl

Version: 1.9

Type: local

Agent: unix

Published: 2011/01/06

Updated: 2018/12/01

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:evince, p-cpe:/a:canonical:ubuntu_linux:evince-common, p-cpe:/a:canonical:ubuntu_linux:evince-dbg, p-cpe:/a:canonical:ubuntu_linux:evince-gtk, p-cpe:/a:canonical:ubuntu_linux:evince-gtk-dbg, p-cpe:/a:canonical:ubuntu_linux:gir1.0-evince-2.32, p-cpe:/a:canonical:ubuntu_linux:libevdocument-dev, p-cpe:/a:canonical:ubuntu_linux:libevdocument1, p-cpe:/a:canonical:ubuntu_linux:libevdocument2, p-cpe:/a:canonical:ubuntu_linux:libevdocument3, p-cpe:/a:canonical:ubuntu_linux:libevview-dev, p-cpe:/a:canonical:ubuntu_linux:libevview1, p-cpe:/a:canonical:ubuntu_linux:libevview2, p-cpe:/a:canonical:ubuntu_linux:libevview3, cpe:/o:canonical:ubuntu_linux:10.04:-:lts, cpe:/o:canonical:ubuntu_linux:10.10, cpe:/o:canonical:ubuntu_linux:8.04:-:lts, cpe:/o:canonical:ubuntu_linux:9.10

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2011/01/05

Reference Information

CVE: CVE-2010-2640, CVE-2010-2641, CVE-2010-2642, CVE-2010-2643

USN: 1035-1