ProFTPD < 1.3.3d 'mod_sql' Buffer Overflow

Medium Nessus Plugin ID 51366


The remote FTP server is affected by a heap-based buffer overflow vulnerability.


The remote host is using ProFTPD, a free FTP server for Unix and Linux.

According to its banner, the version of ProFTPD installed on the remote host is earlier than 1.3.3d. Such versions are reportedly affected by a heap-based buffer overflow vulnerability in the function 'sql_prepare_where()' in the file 'contrib/mod_sql.c'. An unauthenticated, remote attacker may be able to exploit this in combination with an earlier SQL injection vulnerability (CVE-2009-0542) to execute arbitrary code with root privileges.

Note that Nessus did not actually test for the flaw but instead has relied on the version in ProFTPD's banner.


Upgrade to ProFTPD version 1.3.3d or later.

See Also

Plugin Details

Severity: Medium

ID: 51366

File Name: proftpd_1_3_3d.nasl

Version: $Revision: 1.13 $

Type: remote

Family: FTP

Published: 2010/12/23

Modified: 2018/02/20

Dependencies: 10092

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:proftpd:proftpd

Required KB Items: ftp/proftpd, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/12/17

Vulnerability Publication Date: 2010/11/18

Reference Information

CVE: CVE-2010-4652

BID: 44933

OSVDB: 70782