Adobe Photoshop CS5 < 12.0.2 (APSB10-30)

High Nessus Plugin ID 51189


The remote Windows host has an application that is affected by unspecified vulnerabilities.


The installed version of Adobe Photoshop is older than 12.0.2, and hence affected by the following issues :

- Insecure library loading, which could result in arbitrary code execution. (CVE-2010-3127)

- Multiple unspecified vulnerabilities.


Apply Adobe Photoshop 12.0.2 update or later.

Although version 12.0.2 is considered non-vulnerable, Adobe recommends upgrading to 12.0.3 or later. Version 12.0.3 reportedly fixes high priority, non-security related bugs.

See Also

Plugin Details

Severity: High

ID: 51189

File Name: adobe_photoshop_12_0_2.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2010/12/15

Modified: 2013/01/15

Dependencies: 51188

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:photoshop

Required KB Items: SMB/Adobe_Photoshop/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/12/06

Vulnerability Publication Date: 2010/12/06

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-3127

BID: 45359, 45492

OSVDB: 67545, 69789

EDB-ID: 14741

Secunia: 41060, 42492