ClamAV < 0.96.5 Multiple Vulnerabilities

High Nessus Plugin ID 51125


The remote antivirus service is affected by multiple vulnerabilities.


According to its version, the clamd antivirus daemon on the remote host is earlier than 0.96.5. Such versions are reportedly affected by multiple vulnerabilities :

- Multiple errors exist in the PDF processing functions in 'libclamav/pdf.c', which could lead to application crashes. (Bugs 2358, 2380, 2396)

- An off-by-one error exists in the handling of icons such that a crafted icon may be used to cause an integer overflow. (Bug 2344)


Upgrade to ClamAV 0.96.5 or later.

See Also

Plugin Details

Severity: High

ID: 51125

File Name: clamav_0_96_5.nasl

Version: $Revision: 1.12 $

Type: remote

Family: Misc.

Published: 2010/12/10

Modified: 2016/05/04

Dependencies: 39436

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:clamav:clamav

Required KB Items: Antivirus/ClamAV/version, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/11/30

Vulnerability Publication Date: 2010/11/30

Reference Information

CVE: CVE-2010-4260, CVE-2010-4261, CVE-2010-4479

BID: 45152

OSVDB: 69611, 69612, 69656

Secunia: 42426