Wireshark < 1.2.13 / 1.4.2 Multiple Vulnerabilities

medium Nessus Plugin ID 50678


New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Windows host contains an application that is affected by multiple vulnerabilities.


The installed version of Wireshark is 1.2.x less than 1.2.13 or 1.4.x less than 1.4.2. Such versions are affected by the following vulnerabilities:

- An error exists in the LDSS dissector that allows a series of malformed packets to cause a buffer overflow. (5318)

- An error exists in the ZigBee ZCL dissector that allows a series of malformed packets to cause the dissector to enter an infinite loop. (5303)


Upgrade to Wireshark version 1.2.13 / 1.4.2 or later.

See Also





Plugin Details

Severity: Medium

ID: 50678

File Name: wireshark_1_4_2.nasl

Version: 1.9

Type: local

Agent: windows

Family: Windows

Published: 11/22/2010

Updated: 11/15/2018

Dependencies: wireshark_installed.nasl

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/18/2010

Vulnerability Publication Date: 11/18/2010

Reference Information

CVE: CVE-2010-4300, CVE-2010-4301

BID: 44986, 44987

EDB-ID: 15973

Secunia: 42290