Safari < 5.0.3 Multiple Vulnerabilities

High Nessus Plugin ID 50654

Synopsis

The remote host contains a web browser that is affected by several vulnerabilities.

Description

The version of Safari installed on the remote Windows host is earlier than 5.0.3. As such, it is potentially affected by numerous issues in its WebKit component that could allow arbitrary code execution, session tracking, address bar spoofing, and other sorts of attacks.

Solution

Upgrade to Safari 5.0.3 or later.

See Also

http://support.apple.com/kb/HT4455

http://lists.apple.com/archives/security-announce/2010/Nov/msg00002.html

Plugin Details

Severity: High

ID: 50654

File Name: safari_5_0_3.nasl

Version: 1.14

Type: local

Agent: windows

Family: Windows

Published: 2010/11/18

Updated: 2018/07/27

Dependencies: 31788

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: SMB/Safari/FileVersion

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/11/18

Vulnerability Publication Date: 2010/09/08

Reference Information

CVE: CVE-2010-1812, CVE-2010-1813, CVE-2010-1814, CVE-2010-1815, CVE-2010-1822, CVE-2010-3116, CVE-2010-3257, CVE-2010-3259, CVE-2010-3803, CVE-2010-3804, CVE-2010-3805, CVE-2010-3808, CVE-2010-3809, CVE-2010-3810, CVE-2010-3811, CVE-2010-3812, CVE-2010-3813, CVE-2010-3816, CVE-2010-3817, CVE-2010-3818, CVE-2010-3819, CVE-2010-3820, CVE-2010-3821, CVE-2010-3822, CVE-2010-3823, CVE-2010-3824, CVE-2010-3826

BID: 43079, 43081, 43083, 44200, 44206, 44950, 44952, 44953, 44954, 44955, 44956, 44957, 44958, 44959, 44960, 44961, 44962, 44963, 44964, 44965, 44967, 44969, 44970, 44971