VLC Media Player < 1.1.5 Buffer Overflow

High Nessus Plugin ID 50650


The remote Windows host contains a media player that allows arbitrary code execution.


The version of VLC media player installed on the remote Windows host is earlier than 1.1.5. Such versions are vulnerable to a stack smashing attack in the Samba network share access module due to an error in the way VLC calls the Windows API function 'WNetAddConnection2A()' when opening 'smb://' URLs.

If an attacker can trick a user into opening a specially crafted URL with the affected application, he can leverage this issue to execute arbitrary code subject to that user's permissions.


Upgrade to VLC Media Player version 1.1.5 or later.

See Also




Plugin Details

Severity: High

ID: 50650

File Name: vlc_1_1_5.nasl

Version: $Revision: 1.4 $

Type: local

Agent: windows

Family: Windows

Published: 2010/11/18

Modified: 2011/10/24

Dependencies: 31852

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/11/02

Vulnerability Publication Date: 2010/10/26

Reference Information

BID: 44909

OSVDB: 69288

Secunia: 42244