GLSA-201011-01 : GNU C library: Multiple vulnerabilities

High Nessus Plugin ID 50605


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201011-01 (GNU C library: Multiple vulnerabilities)

Multiple vulnerabilities were found in glibc, amongst others the widely-known recent LD_AUDIT and $ORIGIN issues. For further information please consult the CVE entries referenced below.
Impact :

A local attacker could execute arbitrary code as root, cause a Denial of Service, or gain privileges. Additionally, a user-assisted remote attacker could cause the execution of arbitrary code, and a context-dependent attacker could cause a Denial of Service.
Workaround :

There is no known workaround at this time.


All GNU C library users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-libs/glibc-2.11.2-r3'

See Also

Plugin Details

Severity: High

ID: 50605

File Name: gentoo_GLSA-201011-01.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2010/11/16

Modified: 2018/02/14

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:glibc, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/11/15

Exploitable With


Core Impact

Metasploit (glibc LD_AUDIT Arbitrary DSO Load Privilege Escalation)

Reference Information

CVE: CVE-2009-4880, CVE-2009-4881, CVE-2010-0296, CVE-2010-0830, CVE-2010-3847, CVE-2010-3856

BID: 36443, 40063, 44154, 44347

OSVDB: 65077, 65078, 65079, 65080, 68721, 68920, 73407

GLSA: 201011-01