Apache Tomcat 3.x < 3.3.2 Multiple Vulnerabilities

medium Nessus Plugin ID 50526

Synopsis

The remote Apache Tomcat server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the instance of Apache Tomcat 3.x listening on the remote host is prior to 3.3.2, It is, therefore, affected by multiple vulnerabilities.

Unspecified cross-site scripting vulnerabilities exist in the 'ROOT' and example applications shipped with this version of Tomcat.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 3.3.2 or later.

See Also

http://tomcat.apache.org/security-3.html#Fixed_in_Apache_Tomcat_3.3.2

https://seclists.org/bugtraq/2007/Aug/19

Plugin Details

Severity: Medium

ID: 50526

File Name: tomcat_3_3_2.nasl

Version: 1.20

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 11/9/2010

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.2

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2003-0044

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat

Exploit Ease: No known exploits are available

Patch Publication Date: 3/7/2004

Vulnerability Publication Date: 1/25/2003

Reference Information

CVE: CVE-2003-0044, CVE-2007-3384

BID: 6720, 25174

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990