Debian DSA-2123-1 : nss - several vulnerabilities

high Nessus Plugin ID 50452

Language:

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 6.1

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities have been discovered in Mozilla's Network Security Services (NSS) library. The Common Vulnerabilities and Exposures project identifies the following problems :

- CVE-2010-3170 NSS recognizes a wildcard IP address in the subject's Common Name field of an X.509 certificate, which might allow man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority.

- CVE-2010-3173 NSS does not properly set the minimum key length for Diffie-Hellman Ephemeral (DHE) mode, which makes it easier for remote attackers to defeat cryptographic protection mechanisms via a brute-force attack.

Solution

Upgrade the NSS packages.

For the stable distribution (lenny), these problems have been fixed in version 3.12.3.1-0lenny2.

See Also

https://security-tracker.debian.org/tracker/CVE-2010-3170

https://security-tracker.debian.org/tracker/CVE-2010-3173

https://www.debian.org/security/2010/dsa-2123

Plugin Details

Severity: High

ID: 50452

File Name: debian_DSA-2123.nasl

Version: 1.16

Type: local

Agent: unix

Published: 11/3/2010

Updated: 1/4/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: High

VPR Score: 6.1

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:nss, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 11/1/2010

Reference Information

CVE: CVE-2010-3170, CVE-2010-3173

BID: 42817

DSA: 2123