Firefox 3.6 < 3.6.12 Buffer Overflow

High Nessus Plugin ID 50383


The remote Windows host contains a web browser affected by a buffer overflow vulnerability.


The installed version of Firefox 3.6 is earlier than 3.6.12. Such versions are potentially affected by a heap-based buffer overflow vulnerability.

The combination of DOM insertions and the handling of the JavaScript function 'document.write()' exposes an error that can lead to a heap-based buffer overflow.

Note that there have been reports that this issue is being actively exploited in the wild.


Upgrade to Firefox 3.6.12 or later.

See Also

Plugin Details

Severity: High

ID: 50383

File Name: mozilla_firefox_3612.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2010/10/28

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/10/27

Vulnerability Publication Date: 2010/10/26

Exploitable With


Metasploit (Mozilla Firefox Interleaved document.write/appendChild Memory Corruption)

Reference Information

CVE: CVE-2010-3765

BID: 44425

OSVDB: 68905

EDB-ID: 15342

Secunia: 41957