Mandriva Linux Security Advisory : libsmi (MDVSA-2010:209)

High Nessus Plugin ID 50313


The remote Mandriva Linux host is missing one or more security updates.


A buffer overflow was discovered in libsmi when long OID was given in numerical form. This could lead to arbitrary code execution (CVE-2010-2891).

Packages for 2009.0 are provided as of the Extended Maintenance Program. Please visit this link to learn more: 90

The updated packages have been patched to correct this issue.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 50313

File Name: mandriva_MDVSA-2010-209.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2010/10/24

Modified: 2014/04/15

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64smi-devel, p-cpe:/a:mandriva:linux:lib64smi2, p-cpe:/a:mandriva:linux:libsmi-devel, p-cpe:/a:mandriva:linux:libsmi-mibs-ext, p-cpe:/a:mandriva:linux:libsmi-mibs-std, p-cpe:/a:mandriva:linux:libsmi2, p-cpe:/a:mandriva:linux:smi-tools, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2009.1, cpe:/o:mandriva:linux:2010.0, cpe:/o:mandriva:linux:2010.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/10/22

Reference Information

CVE: CVE-2010-2891

BID: 44276

MDVSA: 2010:209