Firefox 3.6 < 3.6.11 Multiple Vulnerabilities

High Nessus Plugin ID 50085


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox 3.6 is earlier than 3.6.11. Such versions are potentially affected by the following security issues :

- Multiple memory safety bugs could lead to memory corruption, potentially resulting in arbitrary code execution. (MFSA 2010-64)

- By passing an excessively long string to 'document.write', it may be possible to trigger a buffer overflow condition resulting in arbitrary code execution on the remote system. (MFSA 2010-65)

- A use-after-free error in nsBarProp could allow arbitrary code execution on the remote system.
(MFSA 2010-66)

- A dangling pointer vulnerability in LookupGetterOrSetter could allow arbitrary code execution. (MFSA 2010-67)

- The Gopher parser is affected by a cross-site scripting vulnerability. (MFSA 2010-68)

- It is possible to steal information from a site in a different domain using modal calls. (MFSA 2010-69)

- It is possible to establish a valid SSL connection to a remote host, provided the SSL certificate was created with a common name containing a wild card followed by partial IP address of the remote host.
(MFSA 2010-70)

- A function used to load external libraries on Windows platform could allow loading of unsafe DLLs thus allowing binary planting attacks. (MFSA 2010-71)

- The SSL implementation allows servers to use Diffie-Hellman Ephemeral mode (DHE) with a very short key length. Such key lengths could be easily breakable with modern hardware. (MFSA 2010-72)


Upgrade to Firefox 3.6.11 or later.

See Also

Plugin Details

Severity: High

ID: 50085

File Name: mozilla_firefox_3611.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2010/10/21

Modified: 2017/06/09

Dependencies: 20862

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/10/19

Vulnerability Publication Date: 2010/08/14

Reference Information

CVE: CVE-2010-3170, CVE-2010-3173, CVE-2010-3175, CVE-2010-3176, CVE-2010-3177, CVE-2010-3178, CVE-2010-3179, CVE-2010-3180, CVE-2010-3181, CVE-2010-3183

BID: 42817, 44243, 44245, 44247, 44248, 44249, 44250, 44252, 44253

OSVDB: 68079, 68844, 68846, 68847, 68848, 68849, 68850, 68851, 68852, 68854

Secunia: 41244