Fedora 13 : webkitgtk-1.2.5-1.fc13 (2010-15957)

Critical Nessus Plugin ID 50030

Synopsis

The remote Fedora host is missing a security update.

Description

- New stable release, API and ABI compatible with previous 1.2.x versions.

- The patches to fix the following CVEs are included with help from Vincent Danen and other members of the Red Hat security team :

CVE-2010-3113 CVE-2010-1814 CVE-2010-1812 CVE-2010-1815 CVE-2010-3115 CVE-2010-1807 CVE-2010-3114 CVE-2010-3116 CVE-2010-3257 CVE-2010-3259

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected webkitgtk package.

See Also

https://bugzilla.redhat.com/show_bug.cgi?id=627703

https://bugzilla.redhat.com/show_bug.cgi?id=628032

https://bugzilla.redhat.com/show_bug.cgi?id=628035

https://bugzilla.redhat.com/show_bug.cgi?id=628071

https://bugzilla.redhat.com/show_bug.cgi?id=631939

https://bugzilla.redhat.com/show_bug.cgi?id=631946

https://bugzilla.redhat.com/show_bug.cgi?id=631948

https://bugzilla.redhat.com/show_bug.cgi?id=640353

https://bugzilla.redhat.com/show_bug.cgi?id=640357

https://bugzilla.redhat.com/show_bug.cgi?id=640360

http://www.nessus.org/u?503bcc1b

Plugin Details

Severity: Critical

ID: 50030

File Name: fedora_2010-15957.nasl

Version: 1.13

Type: local

Agent: unix

Published: 2010/10/20

Updated: 2018/07/12

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:webkitgtk, cpe:/o:fedoraproject:fedora:13

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/10/08

Exploitable With

CANVAS (CANVAS)

Core Impact

Reference Information

CVE: CVE-2010-1807, CVE-2010-1812, CVE-2010-1814, CVE-2010-1815, CVE-2010-3113, CVE-2010-3114, CVE-2010-3115, CVE-2010-3116, CVE-2010-3257, CVE-2010-3259

FEDORA: 2010-15957