Wireshark < 1.2.12 / 1.4.1 ASN.1 BER Dissector Denial of Service

medium Nessus Plugin ID 49978


New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Windows host contains an application that is vulnerable to a denial of service attack.


The installed version of Wireshark is 1.2.x less than 1.2.12 or 1.4.x less than 1.4.1. Such versions are affected by a denial of service vulnerability. The ASN.1 BER dissector contains a flaw that can allow a stack overflow that in turn can cause the application to crash.


Upgrade to Wireshark version 1.2.12 / 1.4.1 or later.

See Also




Plugin Details

Severity: Medium

ID: 49978

File Name: wireshark_1_4_1.nasl

Version: 1.10

Type: local

Agent: windows

Family: Windows

Published: 10/14/2010

Updated: 11/15/2018

Dependencies: wireshark_installed.nasl

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 10/11/2010

Vulnerability Publication Date: 9/13/2010

Reference Information

CVE: CVE-2010-3445

BID: 43197

Secunia: 41535