Apache Tomcat 4.x < 4.1.3 Denial of Service

Medium Nessus Plugin ID 49702


The remote Apache Tomcat server is affected by a denial of service vulnerability.


According to its self-reported version number, the instance of Apache Tomcat 4.x listening on the remote host is prior to 4.1.3. It is, therefore, affected by a denial of service vulnerability.

A malicious HTTP request can cause a request processing thread to become unresponsive. Further requests of this type can cause all request processing threads to become unresponsive.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 4.1.3 or later.

See Also



Plugin Details

Severity: Medium

ID: 49702

File Name: tomcat_4_1_3.nasl

Version: $Revision: 1.11 $

Type: remote

Family: Web Servers

Published: 2010/10/01

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2002/08/30

Vulnerability Publication Date: 2002/06/20

Reference Information

CVE: CVE-2002-0935

BID: 5067

OSVDB: 5051