BACnet OPC Client < 1.0.25 Buffer Overflow

High Nessus Plugin ID 49694


The remote Windows host contains a program that is affected by a buffer overflow vulnerability.


BACnet OPC Client has a client-side buffer overflow vulnerability that can be triggered by opening a malicious CSV file. An attacker can execute arbitrary code and failed exploitation attempts may cause a denial of service on the client.


Upgrade to version 1.0.25 or later

Plugin Details

Severity: High

ID: 49694

File Name: scada_bacnet_opc_client_1_0_25.nbin

Version: $Revision: 1.89 $

Type: local

Family: SCADA

Published: 2010/09/24

Modified: 2018/02/14

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/09/21

Vulnerability Publication Date: 2010/09/16

Exploitable With

CANVAS (White_Phosphorus)

Core Impact

Metasploit (BACnet OPC Client Buffer Overflow)

Reference Information

CVE: CVE-2010-4740

BID: 43289

OSVDB: 68096

EDB-ID: 15026

ICSA: 10-264-01

Secunia: 41466