RHEL 3 / 4 / 5 : flash-plugin (RHSA-2010:0706)

High Nessus Plugin ID 49640


The remote Red Hat host is missing a security update.


An updated Adobe Flash Player package that fixes one security issue is now available for Red Hat Enterprise Linux 3 and 4 Extras, and Red Hat Enterprise Linux 5 Supplementary.

The Red Hat Security Response Team has rated this update as having critical security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section.

The flash-plugin package contains a Mozilla Firefox compatible Adobe Flash Player web browser plug-in.

This update fixes one vulnerability in Adobe Flash Player. This vulnerability is detailed on the Adobe security page APSB10-22, listed in the References section. If a victim loaded a page containing specially crafted SWF content, it could cause flash-plugin to crash or, potentially, execute arbitrary code. (CVE-2010-2884)

All users of Adobe Flash Player should install this updated package, which upgrades Flash Player to version for users of Red Hat Enterprise Linux 5 Supplementary, and version 9.0.283 for users of Red Hat Enterprise Linux 3 and 4 Extras.


Update the affected flash-plugin package.

See Also




Plugin Details

Severity: High

ID: 49640

File Name: redhat-RHSA-2010-0706.nasl

Version: $Revision: 1.24 $

Type: local

Agent: unix

Published: 2010/09/22

Modified: 2017/01/04

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:flash-plugin, cpe:/o:redhat:enterprise_linux:3, cpe:/o:redhat:enterprise_linux:4, cpe:/o:redhat:enterprise_linux:4.8, cpe:/o:redhat:enterprise_linux:5

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/09/21

Exploitable With


Core Impact

Reference Information

CVE: CVE-2010-2884

BID: 43205

RHSA: 2010:0706