Flash Player < 9.0.283 / Unspecified Code Execution (APSB10-22)

High Nessus Plugin ID 49307


The remote Windows host contains a browser plug-in that is affected by a code execution vulnerability.


The remote Windows host contains a version of Adobe Flash Player 9.x before 9.0.283 or 10.x earlier than Such versions are potentially affected by an unspecified code execution vulnerability.

Note that there are reports this is being actively exploited in the wild.


Upgrade to Flash Player / 9.0.283 or later.

See Also


Plugin Details

Severity: High

ID: 49307

File Name: flash_player_apsb10-22.nasl

Version: $Revision: 1.19 $

Type: local

Agent: windows

Family: Windows

Published: 2010/09/21

Modified: 2016/12/08

Dependencies: 28211

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/09/20

Vulnerability Publication Date: 2010/09/13

Exploitable With


Core Impact

Reference Information

CVE: CVE-2010-2884

BID: 43205

OSVDB: 68024

CERT: 275289