Google Chrome < 6.0.472.59 Multiple Vulnerabilities

High Nessus Plugin ID 49237


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than 6.0.472.59. Such versions are reportedly affected by multiple vulnerabilities :

- A use-after-free error exists when using document APIs during parse. (Issue #50250)

- A use-after-free error exists in SVG styles.
(Issue #50712)

- A use-after-free error exists with nested SVG elements.
(Issue #51252)

- A race condition exists in console handling.
(Issue #51919)

- An unlikely browser crash exists in pop-up blocking.
(Issue #53176)

- A memory corruption error exists in Geolocation.
(Issue #53394)

- An error exists by failing to prompt for extension history access. (Issue #54006)


Upgrade to Google Chrome 6.0.472.59 or later.

See Also

Plugin Details

Severity: High

ID: 49237

File Name: google_chrome_6_0_472_59.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2010/09/15

Modified: 2017/11/02

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/09/14

Vulnerability Publication Date: 2010/09/14

Reference Information

CVE: CVE-2010-1823, CVE-2010-1824, CVE-2010-1825, CVE-2010-3412, CVE-2010-3413, CVE-2010-3415, CVE-2010-3417

BID: 43228, 46677

OSVDB: 68101, 68102, 68103, 68105, 68106, 68107, 68109

MSVR: MSVR11-001