Mandriva Linux Security Advisory : libglpng (MDVSA-2010:179)

Medium Nessus Plugin ID 49208


The remote Mandriva Linux host is missing one or more security updates.


A vulnerability has been found and corrected in libglpng :

Multiple integer overflows in glpng.c in glpng 1.45 allow context-dependent attackers to execute arbitrary code via a crafted PNG image, related to (1) the pngLoadRawF function and (2) the pngLoadF function, leading to heap-based buffer overflows (CVE-2010-1519).

The updated packages have been patched to correct this issue.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 49208

File Name: mandriva_MDVSA-2010-179.nasl

Version: $Revision: 1.9 $

Type: local

Published: 2010/09/13

Modified: 2016/05/17

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64glpng-devel, p-cpe:/a:mandriva:linux:lib64glpng1, p-cpe:/a:mandriva:linux:libglpng-devel, p-cpe:/a:mandriva:linux:libglpng1, cpe:/o:mandriva:linux:2009.1, cpe:/o:mandriva:linux:2010.0, cpe:/o:mandriva:linux:2010.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/09/12

Reference Information

CVE: CVE-2010-1519

BID: 42379

MDVSA: 2010:179