Ubuntu 10.04 LTS : mountall vulnerability (USN-985-1)

Medium Nessus Plugin ID 49171


The remote Ubuntu host is missing a security-related patch.


Alasdair MacGregor discovered that mountall created a udev rule file with world-writable permissions. A local attacker could exploit this under certain conditions to cause udev to execute arbitrary commands as the root user.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected mountall package.

Plugin Details

Severity: Medium

ID: 49171

File Name: ubuntu_USN-985-1.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2010/09/09

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:mountall, cpe:/o:canonical:ubuntu_linux:10.04:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2010/09/08

Reference Information

CVE: CVE-2010-2961

OSVDB: 67914

USN: 985-1