Fedora 12 : firefox-3.5.12-1.fc12 / galeon-2.0.7-25.fc12 / gnome-python2-extras-2.25.3-20.fc12 / etc (2010-14362)

high Nessus Plugin ID 49164

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Fedora host is missing one or more security updates.

Description

Update to new upstream Firefox version 3.5.12, fixing multiple security issues detailed in the upstream advisories:
http://www.mozilla.org/security/known- vulnerabilities/firefox35.html#firefox3.5.12 Update also includes packages depending on gecko-libs rebuilt against new version of Firefox / XULRunner.

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

See Also

https://www.mozilla.org/en-US/security/known-

https://bugzilla.redhat.com/show_bug.cgi?id=630055

https://bugzilla.redhat.com/show_bug.cgi?id=630056

https://bugzilla.redhat.com/show_bug.cgi?id=630059

https://bugzilla.redhat.com/show_bug.cgi?id=630061

https://bugzilla.redhat.com/show_bug.cgi?id=630062

https://bugzilla.redhat.com/show_bug.cgi?id=630064

https://bugzilla.redhat.com/show_bug.cgi?id=630067

https://bugzilla.redhat.com/show_bug.cgi?id=630069

https://bugzilla.redhat.com/show_bug.cgi?id=630074

https://bugzilla.redhat.com/show_bug.cgi?id=630075

https://bugzilla.redhat.com/show_bug.cgi?id=630078

https://bugzilla.redhat.com/show_bug.cgi?id=631725

http://www.nessus.org/u?3d738fa8

http://www.nessus.org/u?6c08de90

http://www.nessus.org/u?1de2a37f

http://www.nessus.org/u?577f17e4

http://www.nessus.org/u?71a2bb83

http://www.nessus.org/u?e1739145

http://www.nessus.org/u?b0d9d861

Plugin Details

Severity: High

ID: 49164

File Name: fedora_2010-14362.nasl

Version: 1.15

Type: local

Agent: unix

Published: 9/9/2010

Updated: 1/11/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:firefox, p-cpe:/a:fedoraproject:fedora:galeon, p-cpe:/a:fedoraproject:fedora:gnome-python2-extras, p-cpe:/a:fedoraproject:fedora:gnome-web-photo, p-cpe:/a:fedoraproject:fedora:mozvoikko, p-cpe:/a:fedoraproject:fedora:perl-Gtk2-MozEmbed, p-cpe:/a:fedoraproject:fedora:xulrunner, cpe:/o:fedoraproject:fedora:12

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 9/9/2010

Vulnerability Publication Date: 9/9/2010

Reference Information

CVE: CVE-2010-2760, CVE-2010-2763, CVE-2010-2764, CVE-2010-2765, CVE-2010-2766, CVE-2010-2767, CVE-2010-2768, CVE-2010-2769, CVE-2010-3166, CVE-2010-3167, CVE-2010-3168, CVE-2010-3169

FEDORA: 2010-14362