Mac OS X : Apple Safari < 5.0.2 / 4.1.2

High Nessus Plugin ID 49143


The remote host contains a web browser that is affected by several vulnerabilities.


The version of Apple Safari installed on the remote Mac OS X host is earlier than 5.0.2 / 4.1.2. As such, it is potentially affected by several issues in the following component :

- WebKit


Upgrade to Apple Safari 5.0.2 / 4.1.2 or later.

See Also

Plugin Details

Severity: High

ID: 49143

File Name: macosx_Safari5_0_2.nasl

Version: $Revision: 1.14 $

Type: local

Agent: macosx

Published: 2010/09/08

Modified: 2016/11/28

Dependencies: 31604

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: Host/local_checks_enabled, Host/uname, Host/MacOSX/Version, MacOSX/Safari/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/09/07

Vulnerability Publication Date: 2010/09/07

Exploitable With


Core Impact

Reference Information

CVE: CVE-2010-1807, CVE-2010-1806

BID: 43047, 43049

OSVDB: 67961, 67962