Adobe Reader < 9.3.4 / 8.2.4 Multiple Vulnerabilities (APSB10-17)

High Nessus Plugin ID 48375

Synopsis

The version of Adobe Reader on the remote Windows host is affected by multiple vulnerabilities.

Description

The version of Adobe Reader installed on the remote host is earlier than 9.3.4 / 8.2.4. Such versions are reportedly affected by multiple vulnerabilities :
- Multiple vulnerabilities in the bundled Flash Player as noted in APSB10-16. (CVE-2010-0209, CVE-2010-2188, CVE-2010-2213, CVE-2010-2214, CVE-2010-2215, CVE-2010-2216)

- A social engineering attack could lead to code execution. (CVE-2010-1240)

- An integer overflow vulnerability could lead to code execution. (CVE-2010-2862)

Solution

Upgrade to Adobe Reader 9.3.4 / 8.2.4 or later.

See Also

http://securityevaluators.com/knowledge/papers/CrashAnalysis.pdf

http://www.adobe.com/support/security/bulletins/apsb10-16.html

http://www.adobe.com/support/security/bulletins/apsb10-17.html

Plugin Details

Severity: High

ID: 48375

File Name: adobe_reader_apsb10-17.nasl

Version: 1.21

Type: local

Agent: windows

Family: Windows

Published: 2010/08/19

Updated: 2018/09/17

Dependencies: 20836

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Acroread/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/08/19

Vulnerability Publication Date: 2010/08/04

Exploitable With

Metasploit (Adobe PDF Escape EXE Social Engineering (No JavaScript))

Reference Information

CVE: CVE-2010-0209, CVE-2010-1240, CVE-2010-2188, CVE-2010-2213, CVE-2010-2214, CVE-2010-2215, CVE-2010-2216, CVE-2010-2862

BID: 39109, 40798, 42203, 42358, 42361, 42362, 42363, 42364

Secunia: 40766, 40907