Adobe Reader < 9.3.4 / 8.2.4 Multiple Vulnerabilities (APSB10-17)

high Nessus Plugin ID 48375



The version of Adobe Reader on the remote Windows host is affected by multiple vulnerabilities.


The version of Adobe Reader installed on the remote host is earlier than 9.3.4 / 8.2.4. Such versions are reportedly affected by multiple vulnerabilities :
- Multiple vulnerabilities in the bundled Flash Player as noted in APSB10-16. (CVE-2010-0209, CVE-2010-2188, CVE-2010-2213, CVE-2010-2214, CVE-2010-2215, CVE-2010-2216)

- A social engineering attack could lead to code execution. (CVE-2010-1240)

- An integer overflow vulnerability could lead to code execution. (CVE-2010-2862)


Upgrade to Adobe Reader 9.3.4 / 8.2.4 or later.

See Also

Plugin Details

Severity: High

ID: 48375

File Name: adobe_reader_apsb10-17.nasl

Version: 1.21

Type: local

Agent: windows

Family: Windows

Published: 8/19/2010

Updated: 9/17/2018

Supported Sensors: Nessus Agent

Risk Information


Risk Factor: Critical

Score: 9.2


Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Acroread/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 8/19/2010

Vulnerability Publication Date: 8/4/2010

Exploitable With

Metasploit (Adobe PDF Escape EXE Social Engineering (No JavaScript))

Reference Information

CVE: CVE-2010-0209, CVE-2010-1240, CVE-2010-2188, CVE-2010-2213, CVE-2010-2214, CVE-2010-2215, CVE-2010-2216, CVE-2010-2862

BID: 39109, 40798, 42203, 42358, 42361, 42362, 42363, 42364

Secunia: 40766, 40907