Adobe AIR < 2.0.3 Multiple Vulnerabilities (APSB10-16)

High Nessus Plugin ID 48299


The remote Windows host contains a version of Adobe AIR that is affected by multiple vulnerabilities.


The remote Windows host contains a version of Adobe AIR that is earlier than 2.0.3. Such versions are affected by multiple memory corruption issues and a click-jacking vulnerability.


Upgrade to Adobe AIR 2.0.3 or later.

See Also

Plugin Details

Severity: High

ID: 48299

File Name: adobe_air_apsb10-16.nasl

Version: $Revision: 1.14 $

Type: local

Agent: windows

Family: Windows

Published: 2010/08/11

Modified: 2016/12/05

Dependencies: 32504

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:adobe:air

Required KB Items: SMB/Adobe_AIR/Version, SMB/Adobe_AIR/Path

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/08/10

Vulnerability Publication Date: 2010/08/10

Reference Information

CVE: CVE-2010-0209, CVE-2010-2188, CVE-2010-2213, CVE-2010-2214, CVE-2010-2215, CVE-2010-2216

BID: 40798, 42358, 42361, 42362, 42363, 42364

OSVDB: 65599, 67057, 67058, 67059, 67060, 67061, 67062

CERT: 660993