Citrix ICA Client Multiple Remote Code Execution Vulnerabilities

High Nessus Plugin ID 48275


The remote host contains an application that is affected by multiple remote code execution vulnerabilities.


The version of Citrix ICA Client installed on the remote host is older than 12.0.3. Such versions are reportedly affected by the following remote code execution vulnerabilities:

A vulnerability can be exploited by tricking a user into connecting to a malicious server, via a malicious '.ICA' file or by other means, making it possible for an attacker to execute arbitrary code on the remote client.

Another vulnerability has been identified in the ICA Client ActiveX Object (ICO) component which can allow an attacker to execute arbitrary code on the remote client.


Upgrade to ICA Client 12.0.3 or later.

See Also

Plugin Details

Severity: High

ID: 48275

File Name: citrix_ica_client_1203.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2010/08/09

Modified: 2015/01/12

Dependencies: 13855

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:citrix:ica_client_for_linux, cpe:/a:citrix:ica_client_for_solaris, cpe:/a:citrix:ica_client_for_windows_mobile

Required KB Items: SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/05/28

Vulnerability Publication Date: 2010/08/02

Reference Information

CVE: CVE-2010-2990, CVE-2010-2991

BID: 42149, 42150

OSVDB: 66829, 66830

Secunia: 40819, 40821

IAVB: 2010-B-0057