Wireshark / Ethereal < 1.0.15 / 1.2.10 Multiple Vulnerabilities

High Nessus Plugin ID 48213


The remote host has an application that is affected by multiple vulnerabilities.


The installed version of Wireshark or Ethereal is potentially affected by multiple vulnerabilities.

- The SigComp Universal Decompressor Virtual Machine could potentially overflow a buffer. (Bug 4867)

- The ANS.1 BER dissector could potentially exhaust the stack memory. (Bug 4984)

- The GSM A RR dissector is affected by denial of service issue. (Bug 4897)

- The IPMI dissector could get stuck in an infinite loop. (Bug 5053)


Upgrade to Wireshark version 1.0.15 / 1.2.10 or later.

See Also



Plugin Details

Severity: High

ID: 48213

File Name: wireshark_1_2_10.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2010/08/02

Modified: 2016/05/06

Dependencies: 34112

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/07/29

Vulnerability Publication Date: 2010/07/29

Reference Information

CVE: CVE-2010-2992, CVE-2010-2993, CVE-2010-2994, CVE-2010-2995

BID: 42618

OSVDB: 65372, 66792, 66793, 67191

Secunia: 40783