Apache 2.2.x < 2.2.16 Multiple Vulnerabilities

Medium Nessus Plugin ID 48205


The remote web server is affected by multiple vulnerabilities.


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.16. It is, therefore, potentially affected by multiple vulnerabilities :

- A denial of service vulnerability in mod_cache and mod_dav. (CVE-2010-1452)
- An information disclosure vulnerability in mod_proxy_ajp, mod_reqtimeout, and mod_proxy_http relating to timeout conditions. Note that this issue only affects Apache on Windows, Netware, and OS/2. (CVE-2010-2068)

Note that the remote web server may not actually be affected by these vulnerabilities. Nessus did not try to determine whether the affected modules are in use or to check for the issues themselves.


Upgrade to Apache version 2.2.16 or later.

See Also





Plugin Details

Severity: Medium

ID: 48205

File Name: apache_2_2_16.nasl

Version: $Revision: 1.25 $

Type: remote

Family: Web Servers

Published: 2010/07/30

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/07/25

Vulnerability Publication Date: 2010/06/11

Reference Information

CVE: CVE-2010-1452, CVE-2010-2068

BID: 40827, 41963

OSVDB: 65654, 66745

Secunia: 40206