Mandriva Linux Security Advisory : python (MDVSA-2010:132)

Medium Nessus Plugin ID 48191


The remote Mandriva Linux host is missing one or more security updates.


Multiple vulnerabilities has been found and corrected in python :

Multiple integer overflows in audioop.c in the audioop module in Ptthon allow context-dependent attackers to cause a denial of service (application crash) via a large fragment, as demonstrated by a call to audioop.lin2lin with a long string in the first argument, leading to a buffer overflow. NOTE: this vulnerability exists because of an incorrect fix for CVE-2008-3143.5 (CVE-2010-1634).

The audioop module in Python does not verify the relationships between size arguments and byte string lengths, which allows context-dependent attackers to cause a denial of service (memory corruption and application crash) via crafted arguments, as demonstrated by a call to audioop.reverse with a one-byte string, a different vulnerability than CVE-2010-1634 (CVE-2010-2089).

Packages for 2008.0 and 2009.0 are provided as of the Extended Maintenance Program. Please visit this link to learn more: 90

The updated packages have been patched to correct these issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 48191

File Name: mandriva_MDVSA-2010-132.nasl

Version: $Revision: 1.10 $

Type: local

Published: 2010/07/30

Modified: 2014/01/08

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64python2.5, p-cpe:/a:mandriva:linux:lib64python2.5-devel, p-cpe:/a:mandriva:linux:lib64python2.6, p-cpe:/a:mandriva:linux:lib64python2.6-devel, p-cpe:/a:mandriva:linux:libpython2.5, p-cpe:/a:mandriva:linux:libpython2.5-devel, p-cpe:/a:mandriva:linux:libpython2.6, p-cpe:/a:mandriva:linux:libpython2.6-devel, p-cpe:/a:mandriva:linux:python, p-cpe:/a:mandriva:linux:python-base, p-cpe:/a:mandriva:linux:python-docs, p-cpe:/a:mandriva:linux:tkinter, p-cpe:/a:mandriva:linux:tkinter-apps, cpe:/o:mandriva:linux:2008.0, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2009.1, cpe:/o:mandriva:linux:2010.0, cpe:/o:mandriva:linux:2010.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/07/14

Reference Information

CVE: CVE-2010-1634, CVE-2010-2089

BID: 40370, 40863

MDVSA: 2010:132