Mandriva Linux Security Advisory : gnome-screensaver (MDVSA-2010:040)

High Nessus Plugin ID 48174

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 7.3

Synopsis

The remote Mandriva Linux host is missing a security update.

Description

Multiple vulnerabilities has been discovered and corrected in gnome-screensaver :

gnome-screensaver 2.28.0 does not resume adherence to its activation settings after an inhibiting application becomes unavailable on the session bus, which allows physically proximate attackers to access an unattended workstation on which screen locking had been intended (CVE-2009-4641).

gnome-screensaver before 2.28.2 allows physically proximate attackers to bypass screen locking and access an unattended workstation by moving the mouse position to an external monitor and then disconnecting that monitor (CVE-2010-0414).

This update provides gnome-screensaver 2.28.3, which is not vulnerable to these issues.

Solution

Update the affected gnome-screensaver package.

Plugin Details

Severity: High

ID: 48174

File Name: mandriva_MDVSA-2010-040.nasl

Version: 1.10

Type: local

Published: 2010/07/30

Updated: 2021/01/06

Dependencies: 12634

Risk Information

Risk Factor: High

VPR Score: 7.3

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gnome-screensaver, cpe:/o:mandriva:linux:2010.0

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2010/02/17

Reference Information

CVE: CVE-2009-4641, CVE-2010-0414

MDVSA: 2010:040