Ubuntu 9.04 : nss vulnerability (USN-927-6)

Medium Nessus Plugin ID 47821


The remote Ubuntu host is missing one or more security-related patches.


USN-927-1 fixed vulnerabilities in NSS on Ubuntu 9.10. This update provides the corresponding updates for Ubuntu 9.04.

Marsh Ray and Steve Dispensa discovered a flaw in the TLS and SSLv3 protocols. If an attacker could perform a man in the middle attack at the start of a TLS connection, the attacker could inject arbitrary content at the beginning of the user's session. This update adds support for the new new renegotiation extension and will use it when the server supports it.

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.


Update the affected packages.

Plugin Details

Severity: Medium

ID: 47821

File Name: ubuntu_USN-927-6.nasl

Version: $Revision: 1.10 $

Type: local

Agent: unix

Published: 2010/07/26

Modified: 2016/05/27

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:libnss3-0d, p-cpe:/a:canonical:ubuntu_linux:libnss3-1d, p-cpe:/a:canonical:ubuntu_linux:libnss3-1d-dbg, p-cpe:/a:canonical:ubuntu_linux:libnss3-dev, p-cpe:/a:canonical:ubuntu_linux:libnss3-tools, cpe:/o:canonical:ubuntu_linux:9.04

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Patch Publication Date: 2010/07/23

Reference Information

CVE: CVE-2009-3555

USN: 927-6

CWE: 310