Debian DSA-2069-1 : znc - denial of service

Low Nessus Plugin ID 47705

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that ZNC, an IRC bouncer, is vulnerable to denial of service attacks via a NULL pointer dereference when traffic statistics are requested while there is an unauthenticated connection.

Solution

Upgrade the znc packages.

For the stable distribution (lenny), the problem has been fixed in version 0.058-2+lenny4.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=584929

https://www.debian.org/security/2010/dsa-2069

Plugin Details

Severity: Low

ID: 47705

File Name: debian_DSA-2069.nasl

Version: 1.11

Type: local

Agent: unix

Published: 2010/07/13

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 3.5

Temporal Score: 2.6

Vector: CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:znc, cpe:/o:debian:debian_linux:5.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/07/11

Reference Information

CVE: CVE-2010-2448

BID: 40982

DSA: 2069