Panda Products RKPavProc.sys IOCTL Handling Vulnerabilities

High Nessus Plugin ID 47697


The remote host contains an antivirus application that is affected by multiple vulnerabilities.


The installed Panda security product is reportedly affected by multiple vulnerabilities in the 'RKPavProc.sys' kernel driver that can be triggered by specially crafted IOCTLs, leading to a NULL pointer dereference or a stack-based buffer overflow. An attacker could leverage these flaws to cause a denial of service or execute arbitrary code on the remote host with elevated privileges.


Apply the appropriate hotfix as discussed in the vendor advisory above.

See Also

Plugin Details

Severity: High

ID: 47697

File Name: panda_ioctl_request_multiple_vulns.nasl

Version: $Revision: 1.7 $

Type: local

Agent: windows

Family: Windows

Published: 2010/07/09

Modified: 2014/06/19

Dependencies: 20283, 13855

Risk Information

Risk Factor: High


Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:pandasecurity:panda_antivirus

Required KB Items: Antivirus/Panda/installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/07/01

Vulnerability Publication Date: 2010/07/06

Reference Information

BID: 41428

OSVDB: 66041, 66042

Secunia: 40506, 40462